	Maya Basics Lesson 3: Introduction
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In the previous lesson you learned how to view your 3D scene by changing between single and four view layouts. It is important for you to learn how to change your views in a more interactive manner so that you can: view your objects close up or far away, select objects more accurately, or view objects from different angles in your perspective view.

In this lesson you learn how to:

· Understand the difference between moving objects in the scene and moving the point of view on the scene.

· Use the dolly, track, and tumble camera tools to change the view of your scene in both the orthographic and perspective views.

· Rotate objects using the transformation tools in the Toolbox.

· Select objects using a variety of techniques.

· Group objects together so they can be transformed as a unit.

· Display objects in both wireframe and shaded modes.

· Use additional primitive objects and options.

	Camera tools


In the lessons so far, when you looked at an object from the top, front, or side views you have been viewing the scene through an orthographic view. Orthographic views appear two-dimensional because the object is displayed using parallel projections of only two axes at a time. (Scooter images courtesy of The Art of Maya)
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When you view the scene through the perspective view, you are viewing the scene in a three-dimensional manner. The perspective view simulates what your scene would look like from a camera's point of view.
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In Maya, you view the scene through a set of virtual cameras. These cameras are either orthographic or perspective in nature. You can adjust how these cameras view the scene using the Camera Tools.

The three primary methods for manipulating the camera view are dolly, tumble, and track.

Dolly Tool

The Dolly Tool gets its name from filmmaking where a camera, mounted on a wheeled tripod, is moved towards or away from the scene. In Maya, dollying allows you to view the items in your scene either close up or from further back.
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To dolly the perspective view

1. Enlarge the scene view to a single perspective view.

2. Do one of the following:

· (Windows) Press the Alt key and drag the mouse to the right while holding down the right button on your mouse.

· (Mac OS X) Press the Option key and drag the mouse to the right while holding down the right button on your mouse.

· (Linux) Press the Alt key and drag the mouse to the right while holding down the left and middle buttons on your mouse.

[image: image5.jpg]A




1. To dolly the camera outwards from the subject in the scene you can perform the same key and mouse combinations as described above but drag the mouse to the left.

Dolly works in both the perspective and orthographic views.

	Tip
If you make an error when adjusting your camera view of the scene, you can reset the camera to its default home setting.

To reset the camera view for a particular orthographic or perspective view:

From the panel menu, select View > Default Home.


Tumble Tool

The Tumble Tool allows you to tumble or rotate the camera's view around a particular center of interest to achieve either a higher or lower vantage point, or a different side angle.
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To tumble the perspective view

· Press the Alt key (Windows & Linux) or the Option key (Mac OS X) and drag the mouse either left or right, or up or down, while holding down the left button on your mouse.

Tumbling the view revolves the camera around the center of the scene view, in whichever direction you drag (left, right, up or down). The Tumble Tool does not work in the orthographic views.
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Track Tool

The Track Tool allows you to move the camera up, down, or sideways in relation to the scene.
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To track the perspective view

· Press the Alt key (Windows & Linux) or the Option key (Mac OS X) and drag the mouse in any direction, while holding down the middle button on your mouse.

The Tracking Tool works for both orthographic and perspective views.
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	Note Even though the objects appear to move across the screen when operating any of the camera tools, it is the viewing camera that is actually moved in relation to the scene, not the objects.

Workflow overview

The columns are made up of multiple primitives that are moved, scaled, and rotated into position. Once the first column is created, with each component named and accurately positioned, you will group and duplicate it to create others.
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To create a polygonal cube for the pedestal

1. From the Main Menu, select Create > Polygon Primitives > Cube > [image: image11.png]


.

2. In the Polygon Cube Options window, select Edit > Reset settings and then set the following options:

· Width: 1.75

· Height: 0.6

· Depth: 1.75

Leave the other options at their default settings.

1. In the Polygon Cube Options window, click Create.

Maya creates a cube primitive and positions it at the origin.

1. In the side view, move the cube upwards (Y axis) so it rests on the top surface of the temple base.

You can do this using the Move Tool or with the Channel Box. If you use the Channel Box, enter a Translate Y value of 2.3.

You may find it useful to dolly or tumble the scene view to obtain a better viewpoint.
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1. In the Channel Box, rename the cube columnPedestal.

To create a polygonal cylinder for the shaft

1. From the main menu, select Create > Polygon Primitives > Cylinder > [image: image13.png]


.

2. In the Polygon Cylinder Options window, select Edit > Reset settings and then set the following options:

· Radius: 0.5

· Height: 6

· Subdivisions Around Axis: 12

Leave the other options at their default settings

1. In the Polygon Cylinder Options window, click Create.

Maya creates the cylinder primitive at the origin.

1. In side view, move the cylinder upwards (Y axis) so it rests on the top surface of columnPedestal.

You can do this using the Move Tool or with the Channel Box. If you use the Channel Box, enter a Translate Y value of 5.6.
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1. In the Channel Box, rename the cube columnShaft.

The capital for the column rests on top of the column and is very similar to the pedestal. You duplicate the pedestal and position the duplicate at the top of the column.

To duplicate the pedestal to create the capital

1. With only columnPedestal selected, select Edit > Duplicate > 
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from the main menu.

The Duplicate Options window appears.

1. In the Duplicate Options window, select Edit > Reset settings and then set the following options:

· Translate: 0 6.6 0

· Scale: 0.8 1.0 0.8

Leave the other options at their default settings.

1. In the Duplicate Options window, click Duplicate.

Maya creates a duplicate of the columnPedestal object and moves and scales it based on the options you set.

Note
If you positioned the geometry for the column using the Transform Tools and your mouse, the Y translate values may be incorrect for your particular model. You may want to continue positioning the objects by visual reference using your mouse.

Using the duplicate options is an alternate method for positioning and scaling duplicated objects when you can anticipate its final location.
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1. In the Channel Box, rename the duplicated cube columnCapital.
The base for the column rests on top of the pedestal. You will create the base using one half of a NURBS sphere primitive and then move and rotate it into position. You will do this by modifying the creation options for the sphere primitive.

To create a NURBS sphere for the column base

1. Select Create > NURBS Primitives > Sphere > [image: image17.png]


.

2. In the NURBS Sphere Options window, select Edit > Reset settings and then set the following options:

· Start Sweep Angle: 0

· End Sweep Angle: 180

· Radius: 0.75

· Number of Sections: 8

· Number of Spans: 4

Leave the other options at their default settings.

1. In the NURBS Sphere Options window, click Create.

Maya creates a half-sphere primitive at the origin. 

To rotate and position the sphere on the pedestal

The sphere needs to be rotated 90 degrees and then positioned on top of the pedestal.

1. In side view, rotate the sphere so that the dome part is pointing up.

This is accomplished by either of the following methods:

· Rotating the sphere about the X axis using the Rotate Tool's manipulator handle.

· Using the Channel Box to change the Rotate X value to
-90.

1. Move the sphere so it rests on the top surface of columnPedestal (Translate Y = 2.6, if you have been inputting values into the Channel Box).

2. Using the Scale Tool, scale the sphere along its Z axis (blue manipulator handle) so that the sphere becomes slightly squashed in appearance.
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When you scale an object non-uniformly along one of its axes, you are scaling it non-proportionally.

[image: image19.jpg]



1. In the Channel Box, rename the sphere columnBase.

Viewing objects in shaded mode

Up to this point, you have been viewing your objects in the default wireframe mode. In wireframe mode, objects appear transparent except for the simple wire outline that indicates their position and general shape. Maya provides several options for displaying objects in a shaded manner. 
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Change the display of your scene so that the objects display as shaded objects.

To display the objects in smooth shaded mode

1. Enlarge your perspective view, and dolly and tumble the scene so you can easily view what you've completed so far.

2. From the panel menu, select Shading > Smooth Shade All.

The objects in your scene display in an opaque dark gray color. You can work with objects in either shaded or unshaded mode for the balance of this lesson.

Grouping objects

When you need to move, scale or rotate multiple objects as one unit it is easier if they have been grouped together so that they transform as one unit.

Many of primitive objects in Maya are grouped objects. For example, the NURBS cube primitive is comprised of 6 flat squares or planes that have been grouped together as one unit. When the plane objects are grouped together they create a hierarchy.

A hierarchy is a collection of nodes or objects that are connected together to form a unit for some purpose. Hierarchies are useful for describing how the objects within them share similar characteristics or attributes; move, scale, rotate for example.

To group the objects for the column

1. Select the four objects that comprise the column simultaneously by doing one of the following:

· With your left mouse button, shift-click each object in turn until the four objects are selected in the scene view.

· With your left mouse button, drag one large bounding box around the column objects in an orthographic view.

It is important that you do not select any of the templeBase objects as part of your selection. If you accidentally select any of the base objects, deselect them.

1. From the main menu, select Edit > Group > 
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2. In the Group Options window, select Edit > Reset settings and then set the following options:

· Group Under: Parent

Leave the other options at their default settings

1. In the Group Options window, click Group.

Maya groups the objects together in a hierarchy. You will learn more about hierarchies in the steps that follow.

The Hypergraph

The Hypergraph is a window that shows how the nodes and their connections are organized in your scene. You view object hierarchies and dependencies in the Hypergraph. Use the Hypergraph to view what happens when you group an object. 

To view the Hypergraph

1. From the view menu, select Panels > Layouts > Two Panes Stacked.

The scene view splits into two viewing panels - each has their own separate view menu. You will set these to view the scene in the upper view and the Hypergraph in the other.

1. From the lower pane menu, select Panels > Panel > Hypergraph.

The Hypergraph panel will display below the scene view panel.

1. At the top of the Hypergraph panel, select the Scene Hierarchy icon.
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1. In the Hypergraph panel, select View > Frame All.

The Hypergraph displays the hierarchy for all of the objects in the scene. This approach to viewing the entities in the scene provides a very graphical approach to viewing all of the various nodes in your scene. 
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In the Hypergraph, each node is represented as a rectangle labelled with an icon that denotes the type of information it represents (for example, surface, shading, and so on). Each node has a unique name assigned to it when it is first created. When you rename your objects, you are actually renaming the node associated with that object.

Some nodes display with a line connecting them. This denotes that they are in a hierarchy and have a dependency structure based on how they were originally grouped.

For the temple's column objects, the hierarchy displays each of the named objects under a node labelled group1. Group1 is the parent node for this hierarchy of objects.

In Maya, when the parent node (sometimes referred to as the root node) is moved, rotated, or scaled in any way, the child nodes (sometimes referred to as the leaf nodes) underneath are also affected.

When you select objects at the top level of a hierarchy and move them, the objects within the hierarchy or group follow.

Note
This system of nodes, attributes, and hierarchies may initially appear somewhat complex, but it is one of the most powerful features of Maya. The node based architecture provides flexibility and power to create complex models, shaders, and animations.

To rename the parent node in the Hypergraph

1. In the Hypergraph, click on the group1 node so it becomes active.

In the scene view, all of the objects in the column group become selected as a result of selecting the group at the top (parent) level of the hierarchy.

1. In the Hypergraph, right-click the top node representing group1 and select Rename from the pop-up menu.

A small text box appears in the node.

1. Enter Column as the new name.

Now that the column is grouped, you need to position it at one corner of the temple base.

To position the column on the temple base

1. Change the display of objects to wireframe mode by tapping the 4 key on your keyboard.

This is a keyboard shortcut. Instead of selecting the item from the menu you can use a single key to implement the command.

Tip
Many of the tools and features in Maya can be accessed using keyboard shortcuts. In Maya, these shortcuts are called Hotkeys. Some Hotkeys are displayed directly beside the menu item, others are listed in the Hotkey editor. For a complete listing of available hotkeys, go to Window > Settings/Preferences > Hotkeys.

1. In the Hypergraph, select the Column at the top node so that Column becomes active in the scene view.

2. In the scene view, use the Move Tool to position Column at the front corner of the temple base as shown below.

[image: image24.jpg]Column positioned
at correr of base





With your first column in position, you can now create a copy of the column and position it on the adjacent corner of the base.

To create a duplicate copy of the column

1. With Column still selected in the Hypergraph, select Edit > Duplicate > 
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The Duplicate Options window appears.

1. In the Duplicate Options window, select Edit > Reset settings and then set the following options:

· Number of Copies: 1

Leave the other options at their default settings.

1. In the Duplicate Options window, click Duplicate.

The Hypergraph view updates to show an additional column object in the scene. The copy also takes on the prefix name of the original group and is now labelled Column1.

In the scene view it appears that nothing was actually duplicated. When an object is duplicated without any transformations the copy is positioned in the same position as the original. The two objects are on top of each other.

You need to move the column into position on the adjacent corner of the temple base.

To move the duplicate column into position on the base

1. In the Hypergraph, ensure Column1 is selected by clicking on its top node so it becomes selected in the scene view.

2. In the scene view, use the Move Tool to position Column1 on the adjacent corner of the temple base as shown below.
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1. From the Toolbox, click the Four View layout shortcut.

The workspace changes to a four view layout and the Hypergraph is no longer displayed.

Selection modes and masks

It isn't always efficient to have the Hypergraph window open when you want to select an object at a particular level within its hierarchy. Maya allows you to select items in different selection modes depending upon your specific needs.

There are three main types of selection modes: Hierarchy, Object and Component. You use these modes in order to mask or limit the selection of other objects in order to select only the types of items you want. When you use a selection mask you are filtering out or masking items you don't want to be chosen as part of the selection. 

The icons for the three modes appear on the Status Line.
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When you first start Maya, the default selection mode is set to Objects. This is useful for much of your selection work with Maya, with a few exceptions. When you want to select items that have been grouped, set the selection mode to Hierarchy.

Tip
If you set the selection mask, it will remain that way until you change it again. If an item won't select for you in Maya, you should check the selection mask setting to see if it is set correctly.

To use the Hierarchy and Combinations selection mask

1. On the Status Line, choose the Select by Hierarchy and Combinations icon

The Selection Mask icons update to display the three selection choices.

1. On the Status Line, choose the Select by hierarchy icon.
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Select by hierarchy ensures that when you select items they are selected at their parent or root node.

1. In the scene view, shift-click Column and Column1 so they are selected simultaneously. (Do not be concerned that they highlight in different colors.)

Pivot points

A pivot point is a specific position in 3D space that is used as a reference for the transformations of objects. All objects (curves, surfaces, groups) have pivot points.

When you group objects in Maya, a new node called a parent node is created for the group of objects. The pivot point for the group's parent node is placed at the origin (0, 0, 0). This is useful if you later want to duplicate and rotate the objects radially (that is, in a circular fashion around the pivot).

To group the two columns

1. Ensure Column and Column1 are selected.

2. From the main menu, select Edit > Group > 
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3. In the Group Options window, select Edit > Reset settings. Set the following options:   Group Under: Parent

4. In the Group Options window, click Group.

Maya groups the objects together in a hierarchy and the pivot point is positioned at the origin. (When the pivot point is relocated to the origin the Move Tool manipulator for the selected group appears at the origin) 

With the two columns grouped, you then duplicate the columns with a rotation option, the groups will duplicate and rotate around the pivot point at the origin (0, 0, 0).

To duplicate and rotate the group

1. With column group selected, select Edit > Duplicate > 
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2. In the Duplicate Options window, select Edit > Reset settings and then set the following options:

· Rotate: 0 90 0

· Number of Copies: 3

3. In the Duplicate Options window, click Duplicate.

The columns are duplicated and rotated by 90 degrees with each copy.
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Save your work

Your temple is taking shape! Save your work before proceeding to the next lesson.

To save your Maya scene

1. To save your Maya scene, select File > Save Scene As.

2. Type Lesson3Columns in the file browser area reserved for file names.

3. Click Save.




